新葡萄娱乐Failed connect to 142.93.83.63:80; Connection refused

改用debian差不多有一半年了,之前一直用fedora,大概3年多,虽然软件包都十分新,总是不太平静,有接触软件用着用着就是机关退出了。

改用debian差不多有一半年了,之前一直为此fedora,大概3年多,虽然软件包都大新,总是不顶稳定,有硌软件用着用着就活动退了。

变了debain之后,这半年还当真是一直从未啥问题,这里总结了有的装配置方式,以后有言语再补充。

变了debain之后,这半年还确确实实是直尚未啥问题,这里总结了有的装置配备方式,以后有话更上。

 

 

1. 安装 deb 包

对以前一直为此yum的我吧,刚开还当真不见面因此。

dpkg -i package.deb

 

1. 安装 deb 包

对以前一直就此yum的自身来说,刚开头还确确实实不见面因此。

dpkg -i package.deb

 

2. 装置与安排 sudo

恰好开头时,没有sudo命令,而且安装debian时设置的用户为没 sudo 权限。

  1. 切换到root用户
  2. apt-get install sudo
  3. 配置 /etc/sudoers,使你的钱户有sudo权限

    root ALL=(ALL:ALL) ALL
    wangyubin ALL=(ALL:ALL) ALL # 添加需要之用户

 

2. 安装及布置 sudo

适起经常,没有sudo命令,而且安装debian时设置的用户也并未 sudo 权限。

root    ALL=(ALL:ALL) ALL
wangyubin    ALL=(ALL:ALL) ALL   # 添加需要的用户

 

3. 装 sudo 不用密码

 

先fedora时习惯了非输入密码,所以于debian下为配备了瞬间

# User privilege specification
root    ALL=(ALL:ALL) ALL
#wangyubin    ALL=(ALL:ALL) ALL     <-- 这个是需要输入密码的
wangyubin    ALL=NOPASSWD: ALL     <-- 这个是不需要输入密码的

 

3. 装 sudo 不用密码

 

以前fedora时习惯了非输入密码,所以当debian下为布置了瞬间

# User privilege specification
root    ALL=(ALL:ALL) ALL
#wangyubin    ALL=(ALL:ALL) ALL     <-- 这个是需要输入密码的
wangyubin    ALL=NOPASSWD: ALL     <-- 这个是不需要输入密码的

 

4. 多支持中文的 locales

自习惯用E文的网,因为根本还是因此命令执行来操作,图形界面用之免多,而E文输入起来较便于。

  1. sudo dpkg-reconfigure locales
  2. 选择 zh_CN.UTF-8 等几乎单与中文相关的 locale

 

4. 搭支持中文的 locales

自己习惯用E文的系,因为根本都是用命令执行来操作,图形界面用之非多,而E文输入起来较方便。

 

5. 声卡驱动装置

犹已debian7.4版了,没悟出默认居然没声音。。。

  1. http://www.alsa-project.org/snapshot/ 中下载 alsa-driver
  2. 下载后解压安装

    tar -xjf alsa-driver-1.0.25.3584.gb044d.tar.bz2
    cd alsa-driver-1.0.25.3584.gb044d
    ./configure –with-cards=hda-intel –with-card-options=all
    make -j5
    make install

    ls -al locate snd-hda-intel.ko
    alasmixter # 调整音量

补充: 我在AMD cpu的系统山还设置了 sudo apt-get install esound
才可调动音量

 

 

参照文章: http://blog.csdn.net/wangzhilife/article/details/7881722

装过程遭到或会见缺少有确保,

# 遇到 configure: error: required curses helper header not found
sudo apt-get install libncurses5-dev
# 遇到 configure: error: panelw library not found 
./configure --with-curses=ncurses
# 遇到 /bin/bash: xmlto: command not found 
sudo apt-get install xmlto
# 遇到mv: cannot stat `t-ja.gmo': No such file or directory
./configure --disable-nls

 

5. 声卡驱动装置

且曾debian7.4版了,没悟出默认居然没声音。。。

tar -xjf alsa-driver-1.0.25.3584.gb044d.tar.bz2
cd alsa-driver-1.0.25.3584.gb044d
./configure --with-cards=hda-intel --with-card-options=all
make -j5
make install

ls -al `locate snd-hda-intel.ko`
alasmixter # 调整音量

补充: 我当AMD cpu的体系山还设置了 sudo apt-get install esound
才可以调音量

 

 

参照文章: http://blog.csdn.net/wangzhilife/article/details/7881722

设置过程被或许会见少有担保,

# 遇到 configure: error: required curses helper header not found
sudo apt-get install libncurses5-dev
# 遇到 configure: error: panelw library not found 
./configure --with-curses=ncurses
# 遇到 /bin/bash: xmlto: command not found 
sudo apt-get install xmlto
# 遇到mv: cannot stat `t-ja.gmo': No such file or directory
./configure --disable-nls

 

6. 显卡驱动 (ATI显卡)

  1. 勿设置驱动前, 分辨率最多至 1600 * 1200 (我发台intel
    cpu的机器不用装显卡驱动)
  2. 率先通过 lspci 命令查看显卡型号
  3. AMD官网上下载驱动
    http://support.amd.com/zh-cn/download/desktop?os=Linux+x86
  4. 解压驱动, 然后实行安装即可

 

6. 显卡驱动 (ATI显卡)

 

7. fcitx安装

据此习惯了fcitx。

  1. sudo apt-get install fcitx
  2. sudo apt-get install fcitx-pinyin
  3. ~/.bashrc 中长如下内容:

    # fcitx
    export GTK_IM_MODULE=xim
    export XMODIFIERS=”@im=fcitx”
    export QT_IM_MODULE=xim

 

补充:还有同种植配备方式。

touch /etc/X11/Xsession.d/95input
vim /etc/X11/Xsession.d/95input

# 95input 中内容如下:
export XMODIFIERS=@im=fcitx
export XIM=fcitx
export XIM_PROGRAM=fcitx
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=XIM
fcitx

 

7. fcitx安装

就此习惯了fcitx。

# fcitx
export GTK_IM_MODULE=xim
export XMODIFIERS="@im=fcitx"
export QT_IM_MODULE=xim

 

补充:再有平等栽配备方式。

touch /etc/X11/Xsession.d/95input
vim /etc/X11/Xsession.d/95input

# 95input 中内容如下:
export XMODIFIERS[email protected]=fcitx
export XIM=fcitx
export XIM_PROGRAM=fcitx
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=XIM
fcitx

 

8. emacs 中使用 fcitx

安装完毕晚发现 emacs中居然调不发出 fcitx。

  1. dpkg-reconfigure locales (增加 zh_CN 相关的locale)
  2. 以 /etc/default/locale中多一句: LC_CTYPE=zh_CN.UTF-8

 

8. emacs 中使用 fcitx

安装收尾晚意识 emacs中还是调不有 fcitx。

 

9. ssh连接老缓慢

默认的 debian 在于是 ssh
连接远程机器的时候,总是要等一段时间才会唤醒输入密码,刚开头觉得网速慢,后来发觉局域网中也会见等一段时间才连上。

于是,上网搜了化解智:

  1. debian默认的ssh配置在接连其他linux时, 等30秒左右才见面唤醒输入密码
  2. 改文件 /etc/nsswitch.conf

    # 找到 Host 那行, 改也如下形式:
    hosts: files dns [NOTFOUND=return]

 

9. ssh连接老缓慢

默认的 debian 在用 ssh
连接远程机器的时段,总是要对等一段时间才见面提醒输入密码,刚起觉得网速慢,后来察觉局域网中也会等于一段时间才连上。

遂,上网查找了缓解办法:

# 找到 Host 那行, 改为如下形式:
hosts: files dns [NOTFOUND=return]

 

10. 卸载ffmpeg及有关内容

类型中要就此 ffmpeg,debian自带的不胜最旧,于是想把自带的卸载掉还装新的

sudo apt-get remove ffmpeg libav-tools libavdevice53 libavfilter2 libopencv-core2.3 libopencv-imgproc2.3 libtbb2

 

10. 卸载ffmpeg及有关内容

类中如果用 ffmpeg,debian自带的不行最旧,于是想管自带的卸载掉还装新的

sudo apt-get remove ffmpeg libav-tools libavdevice53 libavfilter2 libopencv-core2.3 libopencv-imgproc2.3 libtbb2

 

11. 安时区

sudo cp /usr/share/zoneinfo/Asia/Shanghai /etc/localtime

 

11. 装时区

sudo cp /usr/share/zoneinfo/Asia/Shanghai /etc/localtime

 

12. python 安装 PIL时, 没有jpeg和zlib的支持

纵然安装了 zlib 和 libjpeg 的package之后, 安装PIL仍然

--------------------------------------------------------------------
 *** TKINTER support not available (Tcl/Tk 8.4 libraries needed)
 *** JPEG support not available
 *** ZLIB (PNG/ZIP) support not available
 *** FREETYPE2 support not available
--------------------------------------------------------------------

将 pip install PIL 改化 pip install pillow 即可
(pillow库也是图形处理的库房)

 

12. python 安装 PIL时, 没有jpeg和zlib的支持

不畏安装了 zlib 和 libjpeg 的package之后, 安装PIL仍然

--------------------------------------------------------------------
 *** TKINTER support not available (Tcl/Tk 8.4 libraries needed)
 *** JPEG support not available
 *** ZLIB (PNG/ZIP) support not available
 *** FREETYPE2 support not available
--------------------------------------------------------------------

将 pip install PIL 改成为 pip install pillow 即可
(pillow库也是图形处理的堆栈)

 

13. 配置oracle java 环境

立是为开发android。

cd /opt
sudo tar zxvf ~/tools/jdk-7u51-linux-x64.tar.gz

sudo update-alternatives --install /usr/bin/java java /opt/jdk1.7.0_51/bin/java 1
sudo update-alternatives --install /usr/bin/javac javac /opt/jdk1.7.0_51/bin/javac 1
sudo update-alternatives --set java /opt/jdk1.7.0_51/bin/java
sudo update-alternatives --set javac /opt/jdk1.7.0_51/bin/javac

 

13. 配置oracle java 环境

就是以开发android。

cd /opt
sudo tar zxvf ~/tools/jdk-7u51-linux-x64.tar.gz

sudo update-alternatives --install /usr/bin/java java /opt/jdk1.7.0_51/bin/java 1
sudo update-alternatives --install /usr/bin/javac javac /opt/jdk1.7.0_51/bin/javac 1
sudo update-alternatives --set java /opt/jdk1.7.0_51/bin/java
sudo update-alternatives --set javac /opt/jdk1.7.0_51/bin/javac

 

14. x86_64 架构的 debian 上配备 android 开发条件

欲配备 32bit 之环境

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386 zlib1g:i386

 

14. x86_64 架构的 debian 上配置 android 开发条件

亟需安排 32bit 底条件

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386 zlib1g:i386

 

15. x86_64 架构的 debian 上卸载 32bit 环境

sudo apt-get remove --purge `dpkg --get-selections | grep i386 | awk '{print $1}'`
sudo dpkg --remove-architecture i386

 

15. x86_64 架构的 debian 上卸载 32bit 环境

sudo apt-get remove --purge `dpkg --get-selections | grep i386 | awk '{print $1}'`
sudo dpkg --remove-architecture i386

 

16. 安装 emacs24

debian7.4 stable版本的软件以稳定都较旧. 默认的emacs还是 v23底.

下的不二法门是打源码安装新型的 emacs v24版

# 准备下载,编译源码的环境
sudo apt-get install git-core
sudo apt-get install libxaw7-dev libxpm-dev libpng12-dev libtiff5-dev libgif-dev libjpeg8-dev libgtk2.0-dev libncurses5-dev
sudo apt-get install autoconf automake
sudo apt-get build-dep emacs

# 下载源码 (下面2个源, 先下载试试看, 然后选择一个下载快的)
git clone --depth 1 https://github.com/emacsmirror/emacs.git
git clone --depth 1 git://git.sv.gnu.org/emacs.git

# 开始编译
cd emacs
./autogen.sh
./configure --prefix=/opt/emacs24
make

# 安装
sudo make install

 

16. 安装 emacs24

debian7.4 stable版本的软件以稳定都比旧. 默认的emacs还是 v23底.

下的点子是由源码安装时的 emacs v24版

# 准备下载,编译源码的环境
sudo apt-get install git-core
sudo apt-get install libxaw7-dev libxpm-dev libpng12-dev libtiff5-dev libgif-dev libjpeg8-dev libgtk2.0-dev libncurses5-dev
sudo apt-get install autoconf automake
sudo apt-get build-dep emacs

# 下载源码 (下面2个源, 先下载试试看, 然后选择一个下载快的)
git clone --depth 1 https://github.com/emacsmirror/emacs.git
git clone --depth 1 git://git.sv.gnu.org/emacs.git

# 开始编译
cd emacs
./autogen.sh
./configure --prefix=/opt/emacs24
make

# 安装
sudo make install

 

17. 大抵单git帐号时, ssh认证的装置

  1. ssh默认的民用key 放在 ~/.ssh/id_rsa 文件中

  2. 变更第2个帐号时, 需要如下步骤:

  3.    – ssh-keygen -t rsa -C wangyb@chujuexinxi.com

  4.    – 需要输入key的号, 不可知为此默认名称了 比如: id_rsa_oschina
  5.    – ssh-add id_rsa_oschina (临时增一个ssh key)

  6. 永配置多只 ssh key

    host chujuexinxi.com
    user gituser
    hostname chujuexinxi.com
    port 22
    identityfile ~/.ssh/id_rsa_chujuexinxi_git

    host gitcafe.com
    user git
    hostname gitcafe.com
    port 22
    identityfile ~/.ssh/id_rsa_gitcafe

    host oschina.net
    user git
    hostname git.oschina.net
    port 22
    identityfile ~/.ssh/id_rsa_oschina

 

17. 大多独git帐号时, ssh认证的装置

  1. ssh默认的私key 放在 ~/.ssh/id_rsa 文件中

  2. 变动第2只帐号时, 需要如下步骤:

  3.    – ssh-keygen -t rsa -C
    [email protected]

  4.    – 需要输入key的号, 不能够因此默认名称了 比如: id_rsa_oschina
  5.    – ssh-add id_rsa_oschina (临时加一个ssh key)

  6. 永远配置多个 ssh key

    host chujuexinxi.com
    user gituser
    hostname chujuexinxi.com
    port 22
    identityfile ~/.ssh/id_rsa_chujuexinxi_git

    host gitcafe.com
    user git
    hostname gitcafe.com
    port 22
    identityfile ~/.ssh/id_rsa_gitcafe

    host oschina.net
    user git
    hostname git.oschina.net
    port 22
    identityfile ~/.ssh/id_rsa_oschina

 

18. jpg 文件转 pdf的工具

sudo apt-get install imagemagick
convert 01.jpg 01.pdf

 

18. jpg 文件转 pdf的工具

sudo apt-get install imagemagick
convert 01.jpg 01.pdf

 

19. 自动停止或启动服务

sudo apt-get install sysv-rc-conf
sudo sysv-rc-conf

 

19. 机动终止或启动服务

sudo apt-get install sysv-rc-conf
sudo sysv-rc-conf

 

20. debian 固定IP设置

auto lo eth0
iface lo inet loopback
iface eth0 inet static
address 192.168.1.77
netmask 255.255.255.0  
gateway 192.168.1.1

安IP后重新开网络

/etc/init.d/networking restart

 

20. debian 固定IP设置

auto lo eth0
iface lo inet loopback
iface eth0 inet static
address 192.168.1.77
netmask 255.255.255.0  
gateway 192.168.1.1

装IP后再也开网络

/etc/init.d/networking restart

 

21. debian 7 安装wireshark

默认安装好的 wireshark 只能用root用户来执行,否则提示找不至
*interfaces*

# 安装 wireshark
sudo apt-get install wireshark

# 创建 wireshark 组
sudo groupadd wireshark

# 将你的用户名添加到 wireshark 组
sudo usermod -a -G wireshark YOUR_USER_NAME

# 将 dumpcap 的所属组改为 wireshark
sudo chgrp wireshark /usr/bin/dumpcap

# 改变dumpcap的权限, 让wireshark 组成员可以执行该程序
sudo chmod 750 /usr/bin/dumpcap

# 使用setcap获取权限
sudo setcap cap_net_raw,cap_net_admin=eip /usr/bin/dumpcap

# 验证改变
sudo getcap /usr/bin/dumpcap

 

设置设置好后,需要注销用户更登录或直接还开系统。

21. debian 7 安装wireshark

默认安装好之 wireshark 只能用root用户来实施,否则提示找不顶
*interfaces*

# 安装 wireshark
sudo apt-get install wireshark

# 创建 wireshark 组
sudo groupadd wireshark

# 将你的用户名添加到 wireshark 组
sudo usermod -a -G wireshark YOUR_USER_NAME

# 将 dumpcap 的所属组改为 wireshark
sudo chgrp wireshark /usr/bin/dumpcap

# 改变dumpcap的权限, 让wireshark 组成员可以执行该程序
sudo chmod 750 /usr/bin/dumpcap

# 使用setcap获取权限
sudo setcap cap_net_raw,cap_net_admin=eip /usr/bin/dumpcap

# 验证改变
sudo getcap /usr/bin/dumpcap

 

安装设置完后,需要注销用户还登录还是直接还开系统。

http://www.bkjia.com/Linuxjc/775807.htmlwww.bkjia.comtruehttp://www.bkjia.com/Linuxjc/775807.htmlTechArticle改用debian差不多有半年了,之前一直用fedora,大概3年多,虽然软件包都很新,总是不太稳定,有点软件用着用着就自动退出了。
换了deba…